
 

 
 
 
 
 

VideoStitch Studio v2.2  
User Guide 

 
 
  

1 



VideoStitch Studio User Guide (v2.2) 

Table of contents 
 

Starting with VideoStitch Studio 3 
Software activation 3 
Starting a new project 4 

VideoStitch Studio user interface 6 
VideoStitch Studio panels 6 
Working with the timeline 6 
Project and system information 7 

VideoStitch Studio workflow 9 
Source synchronization 9 

Automatic synchronization 10 
Audio based synchronization 10 
Motion based synchronization 10 
Flash based synchronization 10 

Manual synchronization 11 
Calibration 11 

Automatic calibration 12 
Rig presets calibration 13 
Custom parameters calibration 17 
Manual frame selection 18 

Manual calibration 20 
Color correction 20 

Photometric parameters 21 
Exposure compensation 23 

Stabilization & orientation 27 
Stabilization 28 
Orientation 28 

Output configuration 29 
Output rendering 30 

General settings 30 
Encoder settings 31 
Audio settings 33 
Batch stitcher 34 

Appendix 36 
List of keyboard shortcuts 36 

 

2 
 

Copyright 2016 VideoStitch Inc. 
This guide is protected under copyright law. 



VideoStitch Studio User Guide (v2.2) 

Starting with VideoStitch 
Studio 

1. Software activation 
 

In VideoStitch Studio, click on Help > License 

 

This will open a new window where you can enter your license code 

 
 

Click “OK” to validate the activation 
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The software will appear as registered 

 
 

 

2. Starting a new project 

There are two ways to start a new project: 

● Add media using the File menu 
● Drag and drop your media from your file explorer to VideoStitch Studio user interface. 

To add media through VideoStitch Studio File menu, proceed to the taskbar, click on “File” then 
“Open Media” 

 

This will open a file explorer where you can select the videos you want to import. 

 
 
After validating, the videos will appear in VideoStitch Studio: 
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VideoStitch Studio user 
interface 

1. VideoStitch Studio panels 
VideoStitch Studio user interface is composed of four panels: 

1. Source ​panel displays the input videos 

2. Output* ​ panel allows you to preview the stitched result 

3. Interactive* ​ panel allows you to preview the stitched video in an interactive viewer 

4. Process* ​ panel allows you to adjust your output video settings, and launch the 

processing 

 

The first three panels include VideoStitch Studio timeline. 

2. Working with the timeline 
VideoStitch Studio timeline allows you to play, pause, seek the videos and select the working area.  

 

 

Seek frame 
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The playhead enable the user to seek a specific frame of the video. The preview of the selected frame 
is then displayed in the panel above. 

Select working area 

By dragging the marquees, the user can select a specific working area in the timeline. The selected 
working area is highlighted in light grey. Tools will use this selection as a working area when launched 
(synchronization, calibration, exposure...). 

 

Zoom in and out the timeline 

Some algorithms, like color correction, display their values on the timeline. To see these with more 
precision, or just to be able to precisely seek to a precise frame, you can zoom in and out of the 
timeline. 

Use the slider at the bottom of the timeline to zoom in or out. 

 

 

3. Project and system information  
At the bottom of the software interface, you will be able to see 3 informations: 

1. Current output and preview size (2048*1024 by default when creating a project) 
2. GPU (Graphics Processing Unit) memory used by VideoStitch Studio 
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3. Your graphics card model and its GPU memory 
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VideoStitch Studio workflow 

1. Source synchronization 
Camera arrays are typically hard to start all together at once and need to be accurately synchronized 
for good stitching results. Furthermore, it is impossible to ensure that each frame set will be recorded 
from all cameras simultaneously. Synchronization is the first step in the stitching process. 
To open the synchronization tool, proceed to the taskbar, click on “Window” and then on 
“Synchronization” 

 

The synchronization tool appears on the left of the user interface. 
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1. Automatic synchronization 

 
To ensure the best results and efficiency when using automatic synchronization algorithms, we 
recommend to run them on a sequence instead of the full video. ​B ​est sequence choices are described 
below. 

There are three approaches to synchronize your video inputs. 

1. Audio based synchronization 

VideoStitch Studio audio-based synchronization analyses the videos’ soundtracks to find out when 

they match and automatically adjust synchronization based on this analysis. If you must rely on audio 

to synchronize ​ ​videos, you need to produce sound that is identifiable over the background noise, for 

all cameras. You can for instance clap your hands. This algorithm is not recommended if you are in a 

noisy environment (concert…). 

When using the audio synchronization, make sure to ​select a working area ​ that include a clap or loud 

sound ​. 

2. Motion based synchronization 

The motion algorithm looks for motion in all your input videos, and then align the start and end points 

of this movement. You can for instance sharply give a spin to your rig when starting to record.  

Make sure to ​select a working area ​ that includes your movement. 

3. Flash based synchronization 

This ​ algorithm will search for sudden change in lighting in your sources videos to synchronize them. 

The light from the flash needs to be visible from all your cameras’ viewpoint. You can for instance: 
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● Add a bag on top of you rig and quickly remove it 
● Light on the room you are working in 
● Use synchronized professional flashes... 

Make sure to ​select a working area ​ that includes the flash 

2. Manual synchronization 
 The automatic synchronization is selected by default. To use the manual synchronization, click on the 

“Manual” tab. 

 

With VideoStitch Studio, you can define the synchronization offset manually and instantly review the 
result in the source or output panel. Next to each input a chain icon enables you to “link” videos 
together, so that they remain synchronized if you manually change other offsets. Audio and motion 
algorithm will use these values as hints. 

2. Calibration 
What is a calibration? 

A calibration is a set of parameters that define how the input videos relate to one another so that they 
can be rendered in a 360 panorama. 

VideoStitch Studio provides you both an automatic calibration tool - that will optimize your camera 
geometric setup - and enable you to use your own calibration templates from PTGui or Hugin. 
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To open the calibration tool, proceed to the taskbar, click on “Window” and then on “Calibration” 

  

The calibration tool appears on the left side of the user interface. 

 

1. Automatic calibration 

VideoStitch Studio can automatically calibrate your footage using rig presets or custom camera 
parameters. 
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To set the calibration working area see the ​Working with the timeline​ section. 

1. Rig presets calibration 

Depending on your footage characteristics (resolution, number of videos), VideoStitch Studio will 
suggest a preset in the rig dropdown that you can use as starting point for the calibration. 
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When clicking on the preset available in the rig drop down list, VideoStitch Studio will apply the preset 
and update the output preview. 
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Before applying preset 

 

After applying preset 

 

This will be taken as a starting point for the calibration algorithm. You can then launch the calibration 
algorithm by clicking on “Calibrate on sequence” 
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Before applying calibration 

 

After applying calibration 
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2. Custom parameters calibration 

 

 

By default the rig selected is ‘“Custom”. 
 
To create a custom calibration : 

1. Select your lens type (e.g Fullframe fisheye for GoPro) 
2. Input the FOV of your cameras (e.g 120 for unmodified GoPro) 
3. Click on “Calibrate on sequence” 

 
By default, VideoStitch Studio will automatically select frames from the calibration sequence you 
defined. If you want total control on the calibration, you can calibrate on a list of frames you select 
yourself. 
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3. Manual frame selection 

 

To calibrate on a frame list: 

1. Click on “Manual frame selection” checkbox 
2. Select a frame using the playhead 
3. Click on “Add frame” and repeat steps 2 and 3 until satisfied of your frame list 
4. Launch the calibration by clicking on “Calibrate on frame list” 

 
 
Managing your calibration frames: 
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● To remove a frame from the list select the frame and click on “Remove selected frame” 
● To remove all the frames from the list, click on “Clear all frames” 
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2. Manual calibration 

You may sometimes want to improve the automatic calibration (when your scene doesn’t have 
enough details, or has close objects for instance). VideoStitch Studio is compatible with PTGui and 
Hugin software solutions, that can stitch together still images ​. 

To access the manual calibration menu, click on “Import template” in the calibration tool 

 

After having created your template in PTGui or Hugin, you can import and apply it by ​clickin ​g on 
“Browse calibration...”. 

To reuse a calibration you previously created and imported, you can click on the “Recent calibration” 

dropdown list. This will list the last few files you imported. Click on the template name to import and 

apply it. 

3. Color correction 
To open the color correction tool, go in Window > Color correction 

 

20 
 

Copyright 2016 VideoStitch Inc. 
This guide is protected under copyright law. 



VideoStitch Studio User Guide (v2.2) 

 

1. Photometric parameters 
T ​he photometry algorithm automatically computes your cameras’ response curve and vignetting to 
improve your output quality. Vignetting is a lens d ​istortion effect that affects all the optical lenses. 
This effect is more visible close to the images edges, that tends to be darker at the center. 

The input cameras’ response curve and vignetting can then be used to blend more smoothly the 
images. When applying exposure compensation later, it will also improve the color correction by 
minimizing color and exposure differences between the inputs. 

To launch the photometric calibration, click on “Calibrate photometry” 

You will then see a “Vignette” and “Camera response” tab appear where the result will be displayed 
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2. Exposure compensation 
VideoStitch Studio automatic compensation algorithm analyzes the input videos and computes 
exposure adjustments. It can be applied to a sequence or on the frame currently selected. 

If the calibration is done on a sequence it creates keyframes at a specified frame interval (60 frames by 
default). A new compensation value will be estimated for each keyframe. Between the keyframes, the 
parameters are automatically interpolated so that all the frames are corrected without major 
discontinuities. 

To calibrate on a single frame 
1. Select the frame you want to adjust 
2. Click on “Adjust current frame” 
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To calibrate on a sequence 
1. Set the working area 
2. Click on “Adjust sequence” 

 

Clicking on “Reset sequence” will erase the exposure compensation. 
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Example 

Before exposure compensation 

 

After exposure compensation + white balance 

 

After exposure compensation only 
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Advanced parameters 

You can access exposure compensation advanced parameters by clicking on “Advanced parameters” 

 

Adjust every : ​ interval between each adjustment, a keyframe will be created for each input exposure 
parameter. Lower values process slower but give better results. 

 

Anchor 

26 
 

Copyright 2016 VideoStitch Inc. 
This guide is protected under copyright law. 



VideoStitch Studio User Guide (v2.2) 

You can anchor the exposure to a source that you think will have the correct color correction (not 
pointing the sun or a flash light). This source will be the color reference for the algorithm. If you don’t 
know which one to pick, select “All”. 
 

4. Stabilization & orientation 
Stabilization is useful if your camera has shaken during the video shooting (typically when the camera 

is in movement). It will smooth down the vertical bumping.  

Orientation adjustment will help you to flatten the horizon. 

To open the stabilization and orientation tool, go in Window > Stabilization & orientation 
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1. Stabilization 

 

To stabilize your footage: 
1. Select the working area you want to stabilize 
2. Click on “Stabilize sequence” 

Clicking on “Reset sequence” will erase the stabilization 

2. Orientation 

 

To change the orientation: 
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1. Select the frame on which you want to change the orientation 
2. Click on “Adjust on current frame” 
3. Click and drag your mouse on the output to change the orientation 

After orientation modification 

 

5. Output configuration  
To open the output configuration tool, proceed to the taskbar, click on “Window”  then “Output 
configuration” 
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If you click on “Show input numbers” you will be able to see how your input videos are arranged in the 
panorama 
 
The blender dropdown list lets you select the blending method (linear or multiband). Linear will be 
faster to compute while multiband will give a better quality result. 
 
The feathering slider will let you select a sharp or smooth blending. A smooth blending will give 
smoother transitions by using both images but will create ghosting where there is parallax. A sharp 
blending will give a quicker transition on short distances and look more natural but will still look 
imperfect when there is parallax. 
 

6. Output rendering 
 
To render your 360 video output, switch to the output panel on the right of the interface. You will be 
able to configure the output size, video and audio encoding parameters. 
 

 
 

1. General settings 
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File 
 
Output name and path. By default the output file is created in the same directory than your input 

videos. To change the output path, click on “Browse” and select where you want to video to be 

created 

Size 

Resolution of the output. As a 360*180 output, the resolution ratio will be 2:1. Updating one of the 

values will automatically update the other one. 

The button “Set optimal size” will pick the maximal resolution your camera rig can handle, without 

interpolation.  

Length 

By default the length of the output is defined as the whole video. To process only the current working 

area, check the “Process selected sequence” checkbox. 

After the configuration of the ​video encoder settings ​ and ​audio settings ​, you can render your video. 

● Click on the “Process now” button to start rendering your video immediately 

● Click on “Send to batch” to send the project to the ​batch stitcher​ queue to be processed later  

 

2. Encoder settings 
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Format 

You can render your content as ​mp4 ​ or ​mov ​ for video output and ​jpeg ​, ​png ​ and ​tiff ​ for image 
sequence output 
 
Codec 

You can encode your output using ​ProRes ​, ​H264 ​, ​MPEG2 ​ and ​Motion JPEG 
 

 
 
 
Bitrate mode 

You can choose between VBR and CBR. 
 
Bitrate 

File size = bitrate (kilobits per second) x duration 

Picking the bitrate is doing a compromise between video quality and file size. The optimal bitrate 
depends of the video player you are using to display your video, please check its specification. 
 
Advanced settings 

You can display advanced settings by clicking on the down arrow. 
You will be able to customize the GOP and B-Frames number 
 

32 
 

Copyright 2016 VideoStitch Inc. 
This guide is protected under copyright law. 



VideoStitch Studio User Guide (v2.2) 

 

3. Audio settings 
By default the audio settings are disabled, to activate the settings, click on the “Audio settings” 
checkbox 

 

 
 
Source 

Let you select which audio input (from your video inputs) you want to use in the output 
 
Codec 

You can encode your audio in ​mp3 ​ or ​aac 
 
Bitrate 

You will be able to select between 64/96/128/192kbps 
 
Sample rate 

The sample rate will be 44100Hz for ​mp3 ​ output and 48000Hz for ​aac 
 
Channel layout 

VideoStitch Studio uses stereo layout for the output audio 
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4. Batch stitcher 
 
The batch processing tool allows you to prepare multiple VideoStitch projects and process them all at 

once later. 

To add projects to the batch stitcher, click on "Send to batch" button 

 

You will then be able to create a copy of your project that will be sent to the batch so that you can 

continue editing your project. 

This is especially useful if you need to process the same sequence with multiple calibrations for 

advanced post-processing in a third party software. 

 
 
To launch the batch stitching click on”Stitch!” 
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If you want to remove, reset or edit a project, right click on the project name in the batch stitcher: 

 
 

You are now ready to enjoy creating amazing 360 content! 
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Appendix  

List of keyboard shortcuts 
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